Hirdetés
Hirdetés

Elemi programozási tételek V.: metszet, unió

2 perc olvasás

Elemi programozási tételek V.: metszet, unió

A metszetképzés tétele

Általános feladat: Rendezésünkre áll egy N és egy M elemű halmaz az A() és a B() vektorban ábrázolva. Készítsük el a két halmaz metszetét a C() vektorba!

Hirdetés

Algoritmus:

Eljárás
CN:=0
Ciklus I=1-től N-ig
J:=1
Ciklus amíg J<=M és A(I)<>B(J)
J:=J+1
Ciklus vége
Ha J<=M akkor CN:=CN+1 : C(CN):=A(I)
Ciklus vége
Eljárás vége.

Unióképzés tétele

Általános feladat: Rendezésünkre áll egy N és egy M elemű halmaz az A() és a B() vektorban ábrázolva. Készítsük el a két halmaz egyesítését a C() vektorba!

Algoritmus:

Eljárás
Ciklus I=1-től N-ig
C(I):=A(I)
Ciklus vége
CN:=N
Ciklus J=1-től M-ig
I:=1
Ciklus amíg I<=N és A(I)<>B(J)
I:=I+1
Ciklus vége
Ha I>N akkor CN:=CN+1 : C(CN):=B(J)
Ciklus vége
Eljárás vége.


Iratkozz fel hírlevelünkreNe maradj le a legújabb tételekről!

Értesülj elsőnek a legújabb minőségi tételekről, jegyzetekről és az oldal új funkcióiról!

Ez is érdekelhet még:
A fény polarizációja

Ha a fény polarizálható, akkor a fény transzverzális hullám. Ha az analizátor 0°ill. 180°-os szöget zár be a polarizátorral, akkor...

5 jótanács a pótfelvételihez

A pótfelvételi eljárás rövidsége miatt nem csupán a határidők szűkebbek, de néhány teendő is máshogy alakul, mint az általános eljárásban....

Close