Elemi programozási tételek I.: összegzés, eldöntés, kiválasztás

2 perc olvasás

Elemi programozási tételek I.: összegzés, eldöntés, kiválasztás

Összegzés tétele

Általános feladat: Adott egy N elemű számsorozat. Számoljuk ki az elemek összegét! A sorozatot most és a továbbiakban is az N elemű A(N) vektorban tároljuk.

Algoritmus:

Eljárás
S:=0
Ciklus I=1-től N-ig
S:=S+A(I)
Ciklus vége
Eljárás vége.

Eldöntés tétele

Általános feladat: Adott egy N elemű sorozat és egy, a sorozat elemein értelmezett T tulajdonság. Az algoritmus eredménye: annak eldöntése, hogy van-e a sorozatban legalább egy T tulajdonsággal rendelkező elem.

Algoritmus:

Eljárás
I:=1
Ciklus amíg I<=N és A(I) nem T tulajdonságú
I:=I+1
Ciklus vége
VAN:=I<=N
Eljárás vége

Kiválasztás tétele

Általános feladat: Adott egy N elemű sorozat, egy, a sorozat elemein értelmezett T tulajdonság, valamint azt is tudjuk, hogy a sorozatban van legalább egy T tulajdonságú elem. A feladat ezen elem sorszámának meghatározása.

Algoritmus:

Eljárás
I:=1
Ciklus amíg A(I) nem T tulajdonságú
I:=I+1
Ciklus vége
SORSZ:=I
Eljárás vége.



Iratkozz fel hírlevelünkre

Értesülj elsőnek a legújabb minőségi tételekről, jegyzetekről és az oldal új funkcióiról!

Sikeres feliratkozás

Valami hiba történt!

Ez is érdekelhet még:
A számítógépen leggyakoribb file-kezelő segédprogramjai.

Ismertessen a számítógépen leggyakrabban alkalmazott file-kezelő segédprogramokat!(Pl. Norton Commander) Céljuk: file-ok, file-csoportok, könyvtárak, könyvtárcsoportok műveleteit csoportosan, könnyen, DOS parancsok ismerete...

Algoritmus

Algoritmus fogalma, tulajdonságai, felépítése, algoritmusleíró eszközök. Az algoritmus fogalma: Az algoritmus több, esetleg végtelen sok azonos jellegű, egymástól csak a...

Close