A tartalom eléréséhez kérjük, lépj be!
Kezdd itt
Szavas kereső
Szint kereső
DMA Divat és Művészeti Szakközépiskola
Top 10 feltöltő

Top 10 feltöltő


Elemi programozási tételek I.: összegzés, eldöntés, kiválasztás

VN:F [1.9.22_1171]
Értékeld
Beküldő: - Szólj hozzá
Szint: - Kedvencekhez
Megnézték:
1056
Nyomtasd
Dátum: 2007-12-20 Küldd tovább
  Letöltés

Elemi programozási tételek I.: összegzés, eldöntés, kiválasztás

Összegzés tétele

Általános feladat: Adott egy N elemű számsorozat. Számoljuk ki az elemek összegét! A sorozatot most és a továbbiakban is az N elemű A(N) vektorban tároljuk.

Algoritmus:

Eljárás
S:=0
Ciklus I=1-től N-ig
S:=S+A(I)
Ciklus vége
Eljárás vége.

Eldöntés tétele

Általános feladat: Adott egy N elemű sorozat és egy, a sorozat elemein értelmezett T tulajdonság. Az algoritmus eredménye: annak eldöntése, hogy van-e a sorozatban legalább egy T tulajdonsággal rendelkező elem.

Algoritmus:

Eljárás
I:=1
Ciklus amíg I<=N és A(I) nem T tulajdonságú
I:=I+1
Ciklus vége
VAN:=I<=N
Eljárás vége

Kiválasztás tétele

Általános feladat: Adott egy N elemű sorozat, egy, a sorozat elemein értelmezett T tulajdonság, valamint azt is tudjuk, hogy a sorozatban van legalább egy T tulajdonságú elem. A feladat ezen elem sorszámának meghatározása.

Algoritmus:

Eljárás
I:=1
Ciklus amíg A(I) nem T tulajdonságú
I:=I+1
Ciklus vége
SORSZ:=I
Eljárás vége.


 

Facebook hozzászólok

Facebook hozzászólók

Hozzászólok

Ha szeretnél hozzászólni, lépj be!

Ezt olvastad már?
Milyen nyomtatókat ismer?

Milyen nyomtatókat ismer? Foglalja össze működési elvüket, fôbb jellemzôiket, valamint...

Close